Warning: count(): Parameter must be an array or an object that implements Countable in /membri/tecnologiax/wp-includes/post-template.php on line 275

Warning: A non-numeric value encountered in /membri/tecnologiax/wp-content/plugins/socializer/socializer.php on line 411

Warning: count(): Parameter must be an array or an object that implements Countable in /membri/tecnologiax/wp-includes/post-template.php on line 275

Warning: A non-numeric value encountered in /membri/tecnologiax/wp-content/plugins/socializer/socializer.php on line 411

Warning: count(): Parameter must be an array or an object that implements Countable in /membri/tecnologiax/wp-includes/post-template.php on line 275

Warning: A non-numeric value encountered in /membri/tecnologiax/wp-content/plugins/socializer/socializer.php on line 411

Warning: count(): Parameter must be an array or an object that implements Countable in /membri/tecnologiax/wp-includes/post-template.php on line 275

Warning: A non-numeric value encountered in /membri/tecnologiax/wp-content/plugins/socializer/socializer.php on line 411

Quando un’applicazione richiede una versione specifica di Java


Warning: A non-numeric value encountered in /membri/tecnologiax/wp-content/plugins/socializer/socializer.php on line 411

java

L’utilizzo di versioni non aggiornate dei pacchetti Java porta ad una pericolosa esposizione ai virus durante la navigazione in Rete. Il consiglio è quindi quello di aggiornare Java, come anche il plug-in flash player, ad ogni nuova versione rilasciata, nel caso di Java dalla Oracle.
Purtroppo alcune applicazioni Java hanno una cattiva abitudine, imporre l’utilizzo di una specifica versione per l’installazione o il funzionamento di un’applicazione web. Quante volte avete visto il messaggio: “richiede la presenza di Java 1.x.xx“?  Qualora l’utilizzo dell’applicazione fosse indispensabile, suggeriamo di installare l’ultima versione di Java disponibile quindi di provare a far credere all’applicazione in questione che sul sistema sia presente la vecchia versione di Java quando, in realtà, si sta adoperando una versione molto più aggiornata e quindi decisamente più sicura.
La procedura con windows è abbastanza semplice, avviamo l’editor del registro di sistema,

in Windows XP: Start, Esegui quindi digitare REGEDIT e poi premere [INVIO];

in Windows Vista ed in Windows 7 invece, scrivere REGEDIT nella casella Cerca programmi e file del pulsante Start e poi [INVIO];

in corrispondenza della chiave HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environment si troveranno alcune sottochiavi che corrispondono alle versioni del pacchetto Java installate sul sistema. Qui rinominiamo la sottochiave denominata 1.X.X_XX (dove “X.X_XX” è il numero della release di Java JRE più aggiornata; ad esempio, 1.7.0_17) sostituendo il numero di release richiesto dall’applicazione (ad esempio, 1.5.0_10).

Per rinominare la chiave 1.X.X_XX basterà farvi clic con il tasto destro del mouse quindi scegliere il comando Rinomina. Così facendo, l’installazione di quelle applicazioni che richiedono la presenza di una specifica versione del pacchetto Java dovrebbe andare a buon fine. Al termine della procedura d’installazione, si dovrà ripristinare la denominazione iniziale della chiave (ad esempio HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environment\1.7.0_17).
Molte applicazioni gestionali effettuano il controllo solo al momento dell’installazione o dell’applicazione di un aggiornamento. L’intervento qui illustrato potrebbe quindi rivelarsi risolutivo e mantenere il sistema in sicurezza.


Warning: count(): Parameter must be an array or an object that implements Countable in /membri/tecnologiax/wp-includes/class-wp-comment-query.php on line 405

6 Responses to Quando un’applicazione richiede una versione specifica di Java

  1. Ines Cudna scrive:

    Scusa ma tu… se protocolli con una java vecia ma il browser vuole giàx la 1.8.x coma si fà?

  2. Ewa Sonnet scrive:

    Io uso apple non ho mai avuto problemi.

  3. MAMELI COLL scrive:

    ho appena acquistato windows 8.1 pro ma durante l’installazione da xp si blocca orrore….. cosa posso fare

Lascia un commento

%d blogger hanno fatto clic su Mi Piace per questo: